WordPress 6.4.3 “Incompatible Archive” Bug Fix

WordPress version 6.4.3 was intended as a “security and bug fix” release; however, it unexpectedly introduces disruptive alterations in how it manages zip files, commonly utilized by themes and plugins. More information on these changes can be found here.

Ideally, this substantial modification should have been incorporated into a minor version update, like 6.5, rather than being bundled within a bug/security fix. This situation is frustrating for the typical WordPress user.

If you encounter the “Incompatible Archive” error while attempting to install a theme or plugin via a zip file, here are the ways to fix it.

1. Modify your themes function.php

add_filter( 'unzip_file_use_ziparchive', '__return_false' );

2. Install this temporary patch available as a plugin and activate.

Leave a Reply

Your email address will not be published. Required fields are marked *

[currently]
© 2018 – 2024 Pixelvise. All Rights Reserved.